Microsoft Power BI degraded services may impact Collibra's Power BI integration

Incident

Microsoft Power BI degraded services may impact Collibra's Power BI integration

Status: in progress
Start:
Affected Components:
All AMER APAC EMEA GovCloud Lineage and Integrations Lineage and Integrations Lineage and Integrations Lineage and Integrations Lineage and Integrations
Investigating

Description:   Collibra is aware that Microsoft is currently experiencing a service degradation that may cause your Power BI jobs to slow down or time out. If a job fails, we recommend running it again once Microsoft Power BI services are fully restored.

Note:  While this is a distinct issue, we have escalated it to Microsoft in light of their recent Power BI service instability. We are monitoring the situation closely and will provide updates as they become available.

Thank you for your patience and understanding.

Update

Description:   Since early February, we have identified several performance issues affecting  Power BI . Our Engineering team is working closely with Microsoft to determine the cause and implement a resolution. If you encounter any service degradation or slowdowns, please reach out to  Collibra Support  so we can assist you directly.

Thank you for your patience and understanding.

Identified

Microsoft has identified the root cause and has schedule a fix for March 14, 2026.

Collibra Engineering is working closely with Microsoft to validate the fix prior to release.

Incident #
MI-20260206
Deployment
All